Tips about Windows 10 HyperV Virtual Machine Connectivity Issue

I’ve a Dell Precision M4600 laptop and did a clean Windows 10 install on M4600. Enabled Hyper-v and I was able to launch Hyper-V console. I was able to create virtual machines and build it using ISO however whenever I try to connect to the VM from Hyper-V console, it was giving me the following error. I’m able to resolve the issue with a very dirty work around:) Will explain that dirty thing which I did to resolve the issue at the end of this post!! Trying to keep the suspense :-D.

Cannot connect to the virtual machine. Try to connect again. If the problem persists, contact your system administrator. Would you like to try connecting again?


However, I could see that the VM was working fine from hyper v console screen below !

Capture12I even checked the event logs and Hyper-V event logs nothing much there :-

Windows 10 Hyper-VI’ve reinstalled Windows 10 with clean image using bootable DVD and enabled Hyper-V.  I was able to create Virtual Machine and connect to the machine using Hyper-V console. Check the name of the laptop machine DESKTOP-TES8VBQ (base machine) for future reference.

Windows 10 Hyper-v Issue -1

The Windows 10 laptop name was the default one “DESKTOP-TES8VBQ” and wanted change the laptop name to something easily recognizable. Some name like I used in the first screen shot “Anoop-Dell-Prec”. So, I renamed the laptop (to Anoop-DELL-M460) using the method mentioned in the following post “How to Rename Windows 10 machine” . After the rename and restart of Windows 10 machine, I tried to connect to Hyper-V console. OH !! It gave me a different error as notes below 🙁

An error occurred while attempting to connect to server “Anoop-DELL-M460”, Check that the Virtual Machine Management service is running and that you are authorized to connect to the server

Windows 10 Hyper-v Issue -2

So this gives me an idea about the issue? Any guesses 🙂 Yes, the rename or change of name of Windows 10 machine name is causing Hyper-V console and connectivity issue in Windows 10. I don’t know what is the fix for this issue or is there any easy workaround for this or not. However, I resolved the issue by rebuilding my Dell Precision M4600 laptopwith Windows 10 clean image. I kept the default name which Windows 10 selected automatically. When you try to change the name of the Windows 10 machine the Hyper-V doesn’t like it. My With default name, Hyper-V is happy so as me !!!

I faced this problem only with one of my laptop and other laptop’s Hyper-v is working fine even after rename of machine.

Hyper-V Issue Windows 10

About Author 

Anoop is Microsoft MVP and Veeam Vanguard ! He is a Solution Architect on enterprise client management with more than 13 years of experience (calculation done on the year 2014) in IT. He is Blogger, Speaker and Local User Group Community leader. His main focus is on Device Management technologies like SCCM 2012,Current Branch, Intune. He writes about the technologies like SCCM, SCOM, Windows 10, Azure AD, Microsoft Intune, RMS, Hyper-V etc...

    Find more about me on:
  • googleplus
  • twitter
  • facebook
  • linkedin
  • youtube
Posted in: Windows 10


  1. Olav says:

    Try uninstalling the hyper-v role and add it again after rename, sure that will work

  2. Tony Brown says:

    Hi Anoop, I had a slightly differnt problem here, where after it reboots the first time it says on screen “just a moment” with the dots that rotate in a circular pattern. It never gets past that. However if you build your VM with the NIC disabled, it does get past it and once you had added the name of the person who is going to use the VM it allows you then to re-add the NIC back and carry on…..weird, but works!



  3. Ofir says:

    Hi anoop I have the same problem ,I just upgrade my win7 64bit to win10 pro ,I created the vm and it doesn’t connect , I don’t have a clean install just upgraded it with Microsoft creation tool, I didn’t change the machine name any suggestions?

  4. Cheryl McDiarmid says:

    I am facing the same issue after upgrading automattically from windows 8 to windows 10. I will try the uninstall hyper-v, rename my computer back to the default and then reinstall hyper-v. However, I don’t know what the default computer name was. Is there anyway to find out what it was without wiping the box and reinstalling the os?


    • Cheryl says:

      I waited as long as my patience allowed me and did the following which DID resolve the issue:

      1. Backed up everything

      2. Factory reset (very painful to press that button, gotta say…)

      /Recovery/Reset this PC

      3. After this, my box was back to windows 8.1

      4. Startup asked me for a PC Name but it DIDN’T HAVE A DEFAULT NAME!!! I was pretty livid but proceeded with:


      5. Once windows 8.1 was running, I upgraded to windows 10. Since 8.1 was home edition, so was windows 10

      6. Once windows 10 was installed and working, I activated to windows 10 pro:

      /Activation, click the change product key and enter a valid windows 10 pro product key (it ain’t free)

      7. Once that was finished and my computer restarted, I turned on hyper-v:

      /Programs and Features/Turn Windows features on or off

      Find the “Hyper-V” checkbox and check it

      8. “Hyper-V” installs. Restart your box. Hyper-V is starts up automatically when you start your pc

      9. Open Hyper-V and create your vm. Follow these steps and it worked this time.

  5. Kishore Varanasi says:

    Hi, Add current user to Local admin group or Hyper-V admins group problem will be solved.

Leave a Comment and Contact Anoop